Linux Категория


Компиляция Nginx с модулем google pagespeed

Недавно обнаружил, что в сети довольно трудно найти что-то человеческое на тему сборки http-сервера nginx с допольно популярным модулем google pagespeed. В принципе, задачка не сильно сложная — компилируем и используем. Однако, у тех, кто пока не имеет обширного опыта сборки софта вручную, могут возникнуть сложности. Главнм образом связанные с тем, что если не задать необходимые ключи при конфигурировании — местоположение элементов будет, скажем, не совсем привычным 🙂


Как настроить NGINX для работы с php-fpm

Сегодня речь пойдет о том, как заставить дружить nginx и php-fpm, при этом начисто выбросив apache2 из процесса работы web-сервера. Как показывает практика, наиболее используемые моды apache2 — headers, expires, rewrite. С их задачами легко справляется современный и быстрый nginx. В общем, держать и «кормить» лишнюю сущность не к чему.


Используем php в режиме FastCGI через php-fpm

Еще не так давно клюбой, кто хотел настроить веб-сервер для работы с приложениями на php, выбирал между двумя режимами работы интерпретатора: mod_php (apache2) и PHP FastCGI. Теперь же есть альтернатива, которая выглядит гораздо более вкусно, чем стандартный php fastcgi — PHP-FPM.


Подключение класса phpagi к AGI интерфейсу Asterisk

Тот, кто хоть каким-то образом касался темы IP-телефонии — явно слышал об Asterisk. Asterisk — это гибкая софтварная PBX (АТС), способная делать с телефонией если не все, то очень и очень многое. Astersisk уже давно набирает обороты, однако до недавнего времени был популярен только в кругах «знающих». Подавляющее же большинство так и сидело на классических мини-АТС, расширение которых требует наличия специально обученных людей и немалой суммы денег.


Установка Ruby на Ubuntu с помощью rvm

У вас возникала когда-нибудь необходимость в установке свежей версии Ruby под ubuntu? У меня периодически возникает. Казалось бы, какая проблема тут может быть, ведь в репозитории будет явно не старье. Однако, к примеру, для того, чтобы запустить на сервере удобную и наглядную мониторилку основных ресурсов Scout Realtime необходима версия рубина от 1.9.3, как заявлено на сайте разработчиков. В репозитории у нас версия 1.9.1.